one piece

让Adsense Deluxe广告插件支持新版wordpress

今天终于把wordpress 2.2升级到wordpress 2.8了
非了不少力气。
其中一个问题发现
Adsense Deluxe会出现
You do not have sufficient permissions to access this page
你没有权限访问这个页面
这样的提示。用google搜索了下,问题解决

方法:
第一步:在插件管理中, 选择Deactivate Adsense-Deluxe 插件;
第二步:修改adsense-deluxe.php,1085行左右的admin_head改为admin_menu,即 “admin_head” 然后替换成 “admin_menu”;
第三步:点击 “Update File” ,然后回到插件管理中,选择激活 Adsense Deluxe;
第四步:将adsense-deluxe.php放置于plugins的目录,将adsense-deluxe目录全部删除,否则虽然可以访问插件设置页面,但不能修改设置。
PS:修改如下代码
$MAX_ADS_PER_PAGE = 3; // MAX # of AdSense ads to allow on a given page
可以控制单一页面中广告快最大数量:
接下来就可以顺利进入Adsense Deluxe的设置界面了

Created By: sb123

Form Page: 让Adsense Deluxe广告插件支持新版wordpress


Leave a Reply

You must be logged in to post a comment.